Welcome
Ladies and Gents:

These forums are now closed and registration disabled.

Please join us at our new forum on Proboards. Our hope is that these new forums are more stable, provide more and better features, and allow continuation of the project forums in a safer, more secure, long term environment.

me3explorer.proboards.com

--The ME3Explorer Team

High-Res Salarian Armor

Area for texture-specific, modding-related discussion. Topics that involve models/meshes/actors go in the mesh area. As with other non-toolset related content, answers not guaranteed.

High-Res Salarian Armor

Postby ledbetterman » 30 Jul 2015, 01:25

I'm working on creating a set of high-res textures for the Salarians on Surkesh. So far, I've only upscaled the following textures from their vanilla resolution to double (1024x1024) and applied some filtering to smooth out the pixelated look:
SAL_ARM_CTHb_Haz_Norm_Stack
SAL_ARM_CTHb_Tnt_Diff
SAL_ARM_CTHb_Tnt_Mask
SAL_ARM_CTHb_Tnt_Strp

Upon replacing them via Texplorer, I ran into the weirdest problem. Now all of the lighting on the Salarian soldiers referencing these textures have strange, inverted lighting on them. I've tried replacing the normals with blank versions, blacking out the tint strip (for all that could possibly do), and nothing has fixed this bug. Oddly enough, Mordin is also affected by this (I did replace his textures with JeanLuc's textures from ME2). Reverting Mordin back to his vanilla textures (and normals) didn't fix the problem.

I'm starting to think that by simply expanding the resolution, the textures are jacking up the normals on the mesh somehow.
Does anyone know what could be causing this and how to fix it? I'd really like to re-do all the Salarian textures (their some of the most offensively low-res in game), but I don't want to continue if enlarging the textures screws with the lighting on the characters.

Salarian Armor tex error:
ImageImage
Mordin Armor tex error:
ImageImage
ledbetterman
User
 
Posts: 19
Joined: 28 Jul 2015, 17:43
Has thanked: 2 time
Have thanks: 4 time

Re: High-Res Salarian Armor

Postby Kainzorus Prime » 09 Aug 2015, 14:10

This looks like the normal map glitch, saw this once on weapon models. Your best bet, unless you have backups to pull original normals from, is to take the color texture, put it through the Normal Map filter from the Nvidia tools plugin for photoshop, then convert that apropriately to V8U8 format through directx sdk tool. Import the new normals and the problem should disappear.
User avatar
Kainzorus Prime
User
 
Posts: 126
Joined: 26 May 2013, 20:31
Has thanked: 13 time
Have thanks: 6 time


Return to Texture Discussion

Who is online

Users browsing this forum: No registered users and 0 guests

suspicion-preferred