Welcome
Ladies and Gents:

These forums are now closed and registration disabled.

Please join us at our new forum on Proboards. Our hope is that these new forums are more stable, provide more and better features, and allow continuation of the project forums in a safer, more secure, long term environment.

me3explorer.proboards.com

--The ME3Explorer Team

Stable 3.0 texture installation critical speed increase

User-centric area for specific questions & problems related to using ME3Explorer tools. This is not a modding "how to" area. Read the sticky before posting!

Re: Stable 3.0 texture installation critical speed increase

Postby Blad3Zer0 » 08 Oct 2016, 06:15

SirCxyrtyx wrote:That's... slightly concerning actually? I don't remember making any optimizations to texture installation, and in programming it's not good if something changes and you don't know why, even if it seems like a positive change.

I know why TOCing is faster, since I did spend time on optimizing that.

I hope this is just the result of something I forgot I did.

Edit: Don't mean to be a wet blanket or anything, I'm excited if this all works out. I just hope it hasn't caused problems that have yet to reveal themselves.


@Tarshana, @Alvaro, @CreeperLava

Can you guys check really quick and make sure the texture installations haven't somehow affected anything else? Because I've tested twice now and after my usual texture-installing spree, there's been a game-breaking bug at the opening scene just after the first Citadel docking. Only seems to have been caused after using Texplorer from Stable 3.0, Stable 2.0 seems to work just fine.

I'll have a more detailed report submitted as soon as I can find the right place to do so and after completely verifying that I didn't just screw up somewhere...
Blad3Zer0
User
 
Posts: 223
Joined: 12 Aug 2013, 11:28
Has thanked: 92 time
Have thanks: 28 time

Re: Stable 3.0 texture installation critical speed increase

Postby Tarshana » 08 Oct 2016, 06:37

My 3rd computer is vanilla right now. What textures are you installing; the standard A LOT + Ottemis and/or anything else? What bug are you experiencing? Do you have screenshots and/or a save game before that, like on Mars before chasing Eva?
Tarshana
User
 
Posts: 58
Joined: 21 Aug 2016, 18:14
Has thanked: 3 time
Have thanks: 4 time

Re: Stable 3.0 texture installation critical speed increase

Postby Alvaro » 08 Oct 2016, 18:57

Hi:

Just for the record, I restored vanilla backups for all three games and ran a fresh first time setup.

Everything went fine and specialy, very fast.

Regarding ME3, DLC extraction (almost every DLC installed but multiplayer ones) took 1hour 15mins.

ME3 tree scan just 9 mins.

ME2 tree scan just 3 mins -only 2 DLC´s intalled but both among the largest, LotSB and Arrival-.

ME tree scan 15 mins -BDtS installed.

Then I ran some massive texture modding -courtesy of CreeperLava´s ALOTs mods- and times were cut drasticaly when comparing to Stable 2.0 as well.

All in all, yes, we have now a lightning fast toolset! :)

BTW, I never bothered to check this before but during first time setup and massive texture modding I was checking Windows task manager often and CPU usage was at a stable 30%, RAM usage at a surprising 10% -or lower- and disk usage very very low too, always under 10%. I do not have a top of the line Geth PC but an average one -i5 (4 cores), 16Gb of RAM and SSD-.

@Blad3zer0 --> no issues at my end at all. After running all the previous, I started a new ME3 game PT and reached the Citaded from Mars smoothly!

HTH!
Alvaro
User avatar
Alvaro
User
 
Posts: 83
Joined: 15 Mar 2015, 13:06
Has thanked: 8 time
Have thanks: 12 time

Re: Stable 3.0 texture installation critical speed increase

Postby Blad3Zer0 » 14 Oct 2016, 09:19

Thank you Alvaro. My issue can be disregarded as I have discovered it *was* in fact a product of my own trial and error, on the side of error in this instance. Glad I tested before reporting on GitHub.

Thanks for checking, though!
Blad3Zer0
User
 
Posts: 223
Joined: 12 Aug 2013, 11:28
Has thanked: 92 time
Have thanks: 28 time

Re: Stable 3.0 texture installation critical speed increase

Postby giftfish » 29 Oct 2016, 14:56

I'm going to close and lock this thread. It's not a help request and therefore isn't appropriate for this section.

From now on, please post "Observations" like these about toolset functionality on Git. That way we can tag them with the proper topics, discuss, and re-tag them as bugs, if that's what they turn out to be. Another option would be posting in the relevant tool thread in the toolset dev area, but Texplorer won't have one until after the re-write.

If anyone in this thread does find an actual problem with installation that started in v3.0, please do report on the toolset's Git and not K's, as that would be a new bug.
User avatar
giftfish
Toolset Developer
 
Posts: 1247
Joined: 08 Jan 2016, 02:35
Has thanked: 129 time
Have thanks: 75 time

Previous

Return to Toolset Help

Who is online

Users browsing this forum: No registered users and 0 guests

suspicion-preferred