Welcome
Ladies and Gents:

These forums are now closed and registration disabled.

Please join us at our new forum on Proboards. Our hope is that these new forums are more stable, provide more and better features, and allow continuation of the project forums in a safer, more secure, long term environment.

me3explorer.proboards.com

--The ME3Explorer Team

Normal textures and mipmaps

User-centric area for specific questions & problems related to using ME3Explorer tools. This is not a modding "how to" area. Read the sticky before posting!

Normal textures and mipmaps

Postby Kinkojiro » 09 Oct 2016, 01:45

I wanted to bring this up, just to see if anybody else was having the same issue.

When building the tfc for EGM 1 I had repeated problems with normals that texplorer would say have the wrong mip count (say 10 instead of 11). This caused problem when replacing an existing texture with a same sized texture. I usually had to go back and replace the normal object binary with a much smaller one. I could not be certain whether it is image engine or DTX Texture tool creating the wrong number of mips or texplorer not counting them.

It is very weird it only happened with the normal v8u8 textures. Anyway an artist who worked with me is also having the same issue, so I am wondering whether anybody else is having an problem.
User avatar
Kinkojiro
Modder
 
Posts: 578
Joined: 02 Dec 2013, 04:14
Has thanked: 233 time
Have thanks: 249 time

Re: Normal textures and mipmaps

Postby KFreon » 09 Oct 2016, 05:49

It's been reported before unfortunately. I recall having a look, but it wasn't obvious add to the cause.
Should be fixed eventually.
Sorry :(
User avatar
KFreon
Toolset Developer
 
Posts: 1665
Joined: 16 Apr 2013, 00:57
Has thanked: 83 time
Have thanks: 520 time

Re: Normal textures and mipmaps

Postby giftfish » 10 Oct 2016, 04:08

I don't remember this being an outstanding issue for the stable, and Creeper and I tested a large variety of textures.

Kinko, does it happen with a specific aspect ratio? Also, please take a quick scan through these issues, which were outstanding with the stable. Do any describe your problem?
User avatar
giftfish
Toolset Developer
 
Posts: 1247
Joined: 08 Jan 2016, 02:35
Has thanked: 129 time
Have thanks: 75 time

Re: Normal textures and mipmaps

Postby Ottemis » 14 Dec 2016, 09:02

I think i reported this one no K?
Same issue for me with certain scalp normals.
User avatar
Ottemis
Harbinger
 
Posts: 824
Joined: 11 Mar 2013, 12:14
Has thanked: 225 time
Have thanks: 247 time

Re: Normal textures and mipmaps

Postby Ottemis » 17 Dec 2016, 03:29

I made an issue for it over on github under K's branch a while ago, maybe add in your observations there kinko, maybe it'll help putting it all together
https://github.com/KFreon/KFreons-ME3Explorer/issues/2
User avatar
Ottemis
Harbinger
 
Posts: 824
Joined: 11 Mar 2013, 12:14
Has thanked: 225 time
Have thanks: 247 time


Return to Toolset Help

Who is online

Users browsing this forum: No registered users and 0 guests

suspicion-preferred